
Incident Resource Status System User’s Guide
The Incident Resource Status System (IRSS) is part of the I-Suite group of 
software programs. IRSS is an automated resource tracking system that 
allows you to collect and manage incident resource information. IRSS 
minimizes the time and effort you need to enter and track these resources by 
reducing the paperwork and potential for data entry errors.

IRSS provides a standardized way to check-in resources when they arrive at 
an incident. In the integrated environment, the information entered in IRSS is 
then shared with the other I-Suite programs, including:

• Incident Time Reporting System (ICARS). For tracking incident 
resource costs assigned to an incident.

• Incident Time System (ITS). For collecting and tracking incident 
resource time.

• Incident Action Plan (IAP).For producing Incident Action Plans.

Topics in this guide include the following:

• About this guide
• Getting Started
• Adding and editing an incident name and number
• Adding, editing, and deleting resources
• Working with databases, T-card labels, and Checkout Forms
• Working with Index Lists and table views
• Running and printing reports.
For information about installing IRSS, please refer to the “I-Suite 
Administrator’s Guide,” which is available for download on  
http://isuite@nwcg.gov.

About this guide
This Incident Resource Status System User’s Guide is organized into sections, 
based on the types of tasks you will commonly perform. At the beginning of 
each section you will find an overview of the topics explained. Where 
appropriate, diagrams are shown immediately following each task. Topics in 
this section include:

• Before you begin
• Conventions.

Before you begin
Before using IRSS, you must be feel confident that:

• You are familiar with your personal computer and function keys and 
understand personal computer concepts.

• You are familiar with Windows 2000, Windows XP, or Windows NT and 
can log on and log off.
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Conventions
The following conventions are used within this guide:

1 Button names, option labels, screen names, tab names, and text box 
names appear in bold, in the same case as on your keyboard or screen. For 
example, the second step might instruct you to

2 On the Tools menu, click Options.

• Topics of special interest or hints that will help you perform a specific 
task show a line before and after the text. The text appears in italic type. 
For example, the following note appears in the “Working with tables” 
section.

The percent sign (%) is a “wildcard” that allows you to perform searches 
without specifying the entire filter criteria. You can use one or more 
wildcards in any combination to locate records that match your search.

Getting Started
This section explains the basic concepts and information you need to begin 
using IRSS. Topics in this section include:

• Terms and concepts
• Security
• Logging on and logging off
• Getting help
• Understanding the stand-alone and integrated environments
• Working with tables.

Terms and concepts
This section outlines some of the screens, toolbars, and menus that you will be 
using in IRSS. If you aren’t already familiar with ROSS or have forgotten a 
few things since training, review these terms and concepts before proceeding 
with the remaining sections in this guide.

The IRSS toolbar identifies thirteen buttons that allow you to perform 
common tasks, including:

• Print. Print the current screen, form, or report.

• Edit Resource. Edit an existing record in form view.

• Add Resource. Open a blank form to add a new record.

• Demob Resource. Navigate through selected records in form view. 
Changes the status code to D for “demob” and positions the cursor on the 
Release Date field.
2 September 9, 2004



Incident Resource Status System User’s Guide
• Delete Resource. Delete the selected records form the database. Prompts 
you to verify that you want to complete the delete action.

Do not delete records without first conferring with the Finance and Cost 
groups!

• Reassign Resource. Changes the status of the selected records to R for 
“reassigned.” Creates a second record and duplicates all fields except 
Incident Order Number, Request Number, and Kind/Position. Allows you 
to track resources over time with multiple assignments. The record retains 
the original Order Request Number, no matter how many times you 
reassign it.

• Add/Edit Incident. Add records to or edit records in the Incident table.

• Run Reports. Open the report module and run existing reports.

• Design Reports. Create new custom and advanced reports.

• Print Barcode. Print a barcode label for the selected record(s).

• Print T-Card Labels. Print a T-card label for the selected record(s).

• Print Checkout Form. Print a checkout form for the selected record(s).

• Refresh Data. Refresh the Table View screen.

The following diagram shows the IRSS toolbar and the toolbar buttons.
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The following buttons that display along the left-hand side of your screen 
identify the types of resources you can view:

Aircraft. Display only those resources with the “A” 
request category.

Crews. Display only those resources with the “C” 
request category.

Equipment. Display only those resources with the 
“E” request category.

Overhead. Display only those resources with the “O” 
request category.

All Resources. Display all resource categories.

All Personnel. Display an alphabetical list of all 
personnel on an incident, including names of crew 
members and personnel with equipment and aircraft 
records that have been rostered.
All Vehicles. Display a list of all vehicles that have 
been rostered and the resource they are attached to.
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The following diagram shows screen elements and screen terminology used 
throughout this guide.

Logging on and logging off
This section explains how to log on and log off of IRSS.

To log on to IRSS
1 From your Desktop, double-click the IRSS icon or click Programs from 

the Start menu, point to I-Suite, and then click IRSS.

If you have trouble logging on to IRSS, please refer to the “Handling 
installation problems,” in the “I-Suite Administrator’s Guide,” which is available 
for download on http://isuite@nwcg.gov.

To log off IRSS
• On the File menu, click Exit.
September 9, 2004 5



Incident Resource Status System User’s Guide
Getting help
This section explains how to access and locate help information. There are 
three basic ways to obtain help information for IRSS:

• Access the I-Suite website. This site contains a wide array of I-Suite 
information, including software downloads, updates, and user 
documentation.

• Contact the I-Suite Helpdesk. If you are unable to answer your question 
using the I-Suite website, contact the I-Suite Helpdesk at (866) 224-7677.

• Review this Incident Time System User’s Guide. This guide is 
available in Acrobat format. To locate topics of interest, click to select the 
Bookmark of your choice. Bookmarks are listed along the left-hand side 
of the Acrobat document. When you click the Bookmark, you will 
advance to that topic within the document.

To display help information within IRSS
• On the Help menu, click Support.

The following diagram shows the I-Suite Support dialog box.

To locate help information on the I-Suite website
1 Start your Internet browser.

2 In the Address box, type http://isuite.nwcg.gov, and then press ENTER.

3 On the Welcome to I-Suite webpage, click the IRSS application icon.

4 On the IRSS webpage, click to select the topic of your choice.

To obtain a copy of this Incident Resource Status System User’s 
Guide
1 Start your Internet browser.

2 In the Address box, type http://isuite@nwcg.gov, and then press ENTER.
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3 On the Welcome to I-Suite webpage, click the IRSS application icon.

4 On the IRSS webpage, click to select IRSS User’s Guide.

5 In Acrobat Reader, save the file to your personal computer in a folder 
location of your choice.

Understanding the stand-alone and integrated environments
This section explains the difference between working in the stand-alone 
environment or the integrated environment. While you may only be using 
IRSS for your work, it is important to understand how the information you 
enter in IRSS affects other I-Suite programs.

As a team working in the integrated environment, establish guidelines and 
standard operating procedures (SOPs) that will accommodate all functional 
groups.

• Integrated environment. Using IRSS, enter resources, crews, and 
operators. This data is then shared between the Resource Planning and 
Finance groups. Maintain data standards. Changes, additions, and/or 
deletions to data affect all functional groups.

• Stand-alone environment. While data from IRSS populates other I-Suite 
programs, data ownership issues are eliminated.

Working with tables
In IRSS, resource information display in tables. Using the filtering function in 
IRSS, you can locate and display specific records or subsets of records based 
on your own criteria.

You can filter resource information by three different levels:

• Incident level. Display records associated with one incident at a time.
• Resource type level. Display records based on the resource type: 

Aircraft, Crews, Equipment, Overhead, or all records.
• Selected fields level. Display records by specific field and filter criteria.

To display all resources associated with one incident at a time
1 Click the All Resources button.

2 On the Tools menu, click Options.

3 On the Options dialog box under Manage Multiple Incidents, click As 
One.
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The following diagram shows the Options dialog box. 

The following diagram shows all resources with incidents managed as one.

To display all resources separately
1 Click the All Resources button.

2 On the Tools menu, click Options.

3 On the Options dialog box under Manage Multiple Incidents, click 
Separately.
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The following diagram shows all resources with incidents managed 
separately.

To display records based on the resource type
1 Click the resource type button of your choice

- to display aircraft, click the Aircraft button
- to display crews, click the Crews button
- to display equipment, click the Equipment button
- to display overhead, click the Overhead button.

2 On the Tools menu, click Options.

3 On the Options dialog box under Manage Multiple Incidents, perform 
one of the following

- to manage incidents as one, click As One
- to manage incidents separately, click Separately.
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The following diagram shows crew resources with incidents managed as one.

The following diagram shows crew resources with incidents managed 
separately.

To display records by specific field using a wildcard

The percent sign (%) is a “wildcard” that allows you to perform searches 
without specifying the entire filter criteria. You can use one or more wildcards 
in any combination to locate records that match your search.
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1 Click the resource type button of your choice

- to display aircraft, click the Aircraft button
- to display crews, click the Crews button
- to display equipment, click the Equipment button
- to display overhead, click the Overhead button
- to display all resources, click the All Resources button
- to display all personnel, click the All Personnel button.

2 On the filter bar, click in the box above the column title of your choice.

3 In that box, type the filter criteria of your choice and then click the Filter 
button.

For example: 
- type MA% to search for records beginning with the letters “MA” 
- type %MA to search for records ending with the letters “MA” 
- type %MA% to search for records containing any instance of the letters 

 “MA.”

The following diagram shows a sample wildcard search for personnel records 
with last names containing the letters “MA.”

To deactivate the Filter button, clear the filter criteria from the filter bar, and 
then click the Filter button again. The table will redisplay in its original form.
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Adding and editing an incident name and number
This section explains how to add an incident name and number.

To add an incident name and number
1 On the IRSS menu bar, click the Add/Edit Incident button.

2 On the Incidents dialog box, click in the first available blank row, in the 
cell to the right of the ∗

3 In the Incident Name box, type the name of the new Incident, and then 
press TAB.

4 In the Incident Number box, type the Incident Number, and then click 
the Save button.

The following diagram shows the Incidents dialog box.The arrow points to 
the first blank row where you can begin to add an incident.

To edit an incident name and number
1 On the IRSS toolbar, click the Add/Edit Incident button.

2 To change the Incident Name, click to highlight the Incident Name of 
your choice, and then type to replace the Incident Name.

3 To change the Incident Number, click to highlight the Incident Number 
of your choice, and then type to replace the Incident Number.

4 To save your changes, click the Save button.
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Adding, editing, and deleting resources
This section explains how to add and edit resources, demobilize resources, 
and delete resources. Remember these key points when working with resource 
information:

• Data is organized and presented according to the ICS-211 form.
• Before saving a resource, you must complete the following required fields

- Request Number
- Resource Name
- Configuration
- Kind/Posiiton
- Status.

• Before rostering members or adding additional qualifications, you must 
complete the mandatory fields and save the resource.

• It is better to edit an existing resource than to delete one and then add it 
back to the incident database.

• When you choose a type of resource, the data entry screen options may 
change. Be sure to look over the data entry screen.

• Once you demobilize a resource you can no longer post time to it.
• You can delete resources and/or rostered members of a resource. If there 

are any dependencies attached, IRSS displays warning messages. Be sure 
to read all these warning messages before committing to the delete 
request.

To add resources using an ICS-211 and/or optional check-in form
1 On the IRSS task bar, click the Add Resource icon.

2 On the Add Resource dialog box, complete the following information as 
required or appropriate

- Request number - Kind/Position
- Contracted - Mobilization Date
- Person - Length of Assignment
- Resource Name - Demobilization Date
- Agency - Status
- Configuration - Other (1)
- Check-in Date - Other (2)
- Check-in Time - Other (3)
- Num Personnel - Vehicle ID
- Unit ID - Release Date
- Demob City - Release Time
- Demob State - Original Order/Req Number
- Jetport - Remarks.
- Travel Method

3 Click the Save button.
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The following diagram shows the location of the Add Resource icon.

The following diagram shows the Add Resource dialog box.

Creating strike teams
This section outlines two basic examples for creating a strike team. 
Whichever method you choose, remember these key points:

• Follow the numbering structure set up by the dispatch organization that 
sent you the strike team.

• Add and designate the strike team leader last.
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The following diagram shows the basic process for creating a strike team, 
adding crews, rostering crew members, and adding a strike team leader.

To create a strike team resource - example 1
1 On the IRSS task bar, click the Add Resource icon.

2 On the Add Resource dialog box, complete the following information

- in the Request Number box, type the Request Number of the strike 
team

- click the Agency drop-down arrow, and then click to select the 
Agency of the strike team

- click the Configuration drop-down arrow, and then click to select  
S/T

- complete the Check-in Date and Check-in Time.
- in the Num Personnel box, type the total number of strike team 

members 

3 Complete the following information as required or appropriate

- Unit ID
- Demob City
- Demob State
- Jetport
- Travel Method

4 Click the Kind/Position drop-down arrow, and then click to select the 
strike team type.
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5 Complete the following information as required or appropriate

- Mobilization Date
- Lenght of Assignment (Days)
- Status
- My food
- Pet Names
- Menu Options
- Vehicle ID
- Release Date
- Release Time.

The following diagram shows a sample Add Resource dialog box for adding a 
strike team. Here, a Type 3 Engine Strike Team is created.

To add a crew to the strike team
6 Click the Add S/T, T/F Component button.

7 On the irss dialog box, click the Yes button.
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8 On the Add Strike Team, Task Force Component dialog box, complete 
the following information 

- in the Resource Name box, type the name of the crew
- click the Agency drop-down arrow, and then click to select the 

Agency of the strike team
- click the Configuration drop-down arrow, and then click to select C
- complete the Check-in Date and Check-in Time.
- in the Num Personnel box, type the total number of crew team 

members 

9 Complete the following information as required or appropriate

- Unit ID
- Demob City
- Demob State
- Jetport
- Travel Method

10 Click the Kind/Position drop-down arrow, and then click to select the 
crew type for the strike team.

11 Complete the following information as required or appropriate

- Mobilization Date
- Lenght of Assignment (Days)
- Status
- My food
- Pet Names
- Menu Options
- Vehicle ID
- Release Date
- Release Time.

The following diagram shows the irss dialog box.
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The following diagram shows a completed Add Strike Team, Task Force 
Component dialog box. Here, a Type 3 engine crew of 4 members is being 
added. 

To roster crew team members on the strike team
12 Click the Roster button.

13 On the irss dialog box, click the Yes button.

14 In the Roster section of the Add Strike Team, Task Force Component 
screen, complete the following boxes, pressing TAB after each entry

- Request Num
- Leader
- Last name
- First Name
- Kind
- Status.

After adding the last crew member, be sure to press TAB to advance the 
cursor to the next available blank row. Otherwise, you will not save that 
last entry!

15 When finished rostering that crew, click the Add S/T, T/F Component 
button.
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16 Add additional crews and crew members to the strike team as appropriate.

The following diagram shows the irss dialog box for saving the crew before 
rostering members. 

The following diagram shows a completed Roster for a strike team crew. 
Here, a Type 3 engine crew of 4 members is added.

To add the strike team leader
17 On the Add Strike Team, Task Force Component dialog box, complete 

the following information 

- click to select the Person check box
- in the Last Name box, type the Last Name of the strike team leader
- in the First Name box, type the First Name of the strike team leader
- click the Agency drop-down arrow, and then click to select the 

Agency of the strike team
- click the Configuration drop-down arrow, and then click to select C
- complete the Check-in Date and Check-in Time.
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18 Complete the following information as required or appropriate

- Unit ID
- Demob City
- Demob State
- Jetport
- Travel Method

19 Click the Kind/Position drop-down arrow, and then click to select STEN 
to designate the strike team leader.

20 Complete the following information as required or appropriate

- Mobilization Date
- Lenght of Assignment (Days)
- Status
- My food
- Pet Names
- Menu Options
- Vehicle ID
- Release Date
- Release Time.

21 When finished adding all strike team crews, crew members, and the strike 
team leader, click the Save button.

22 On the irss dialog box, click Yes.
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The following diagram shows the strike team leader being added to the strike 
team. 

The following diagram shows the irss dialog box. Here, you can click Yes to 
finished or click No to continue adding additional strike team components. 

To create a strike team resource - example 2
1 On the IRSS task bar, click the Add Resource icon.

2 Complete the Add Resource dialog box as appropriate, and then click the 
Save button.

3 On the Edit menu, click Strike Teams/Task Forces.

4 On the Edit Strike Team/Task Forces dialog box, click the Select a 
Strike Team or Task Force drop-down arrow, and then click to select the 
Strike Team you created in step 2.
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5 Under Resource List, click the Equipment button, click the Kind drop-
down arrow, and then click to select the Equipment for that Strike Team.

6 Click to select the Equipment of your choice, and then click the Add 
Component button.

7 Click the Overhead button, click the Kind drop-down arrow, and then 
click to select the Overhead of your choice for that Strike Team.

8 Click to select the Overhead of your choice, and then click the Add 
Component button.

9 When finished adding all components for the strike team, click the Close 
button.

The following diagram shows the Edit Strike Team/Task Forces dialog box.

To edit a resource
1 Click to highlight a resource of your choice.

2 On the IRSS task bar, click the Edit Resource icon.

3 On the Edit Resource dialog box, edit the data as appropriate.

4 When finished making your changes, click the Save button.
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The following diagram shows the location of the Edit Resource icon.

The following diagram shows the Edit Resource dialog box.

To add qualifications to a resource
1 Click to highlight a resource of your choice.

2 On the IRSS task bar, click the Edit Resource icon.

3 On the Edit Resources dialog box under Other Quals, click the box, and 
then click the drop-down arrow to select the Code/Description of your 
choice.

4 To designate the qualification as trainee acceptable, click the Trainee 
check box.
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5 Edit the remaining data as appropriate.

6 Click the Save button.

The following diagram shows the Other Quals drop-down arrow on the Edit 
Resources dialog box.

To demobilize a resource
1 Click to highlight a resource of your choice.

2 On the IRSS task bar, click the Edit Resource icon.

3 Click the Status drop-down arrow, and then click to select D to demob the 
resource.

4 Complete the following information

- Release Date
- Release Time.

5 Click the Save button.
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The following diagram shows the Edit Resource dialog box. The arrows point 
to the Status, Release Date, and Release Time boxes.

To delete a resource
1 Click to highlight a resource of your choice.

2 On the IRSS menu bar, click the Delete Records button.

3 On the Delete Resources dialog box, click the Proceed button.

4 On the ISuite Warning dialog box, click Yes to confirm or click No to 
cancel.

The following diagram shows the location of the Delete Records button on the 
IRSS menu bar.
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The following diagram shows the Delete Resources dialog box.

The following diagram shows the ISuite Warning dialog box.

Working with databases, T-card labels, and Checkout 
Forms

The IRSS File menu allows you to perform the following functions:

• Open and close a specific IRSS database. You can have only one 
database open at a time. When you open a database, the previous one is 
automatically closed. 

• Select a printer and printer options.
• Print a T-Card label. T-Card labels identify individual resource 

information. These labels are put on T-Cards, which replaces the hand-
written header information.

• Print a Checkout Form. The Checkout Form keeps track of an 
individual resource that demobs from an incident before actual demob has 
started for the incident. This allows you to print out one checkout form 
without running the checkout form report.

To open another IRSS database

If the database you want to open does not appear on the IRSS Server and 
Database Selection dialog box, you must use the AdminTool. For more 
information see, “Managing your incident databases,” in the “I-Suite 
Administrator’s Guide.”

1 On the File menu, click Open Database.

2 On the IRSS Server and Database Selection dialog box, click the server 
drop-down arrow, and then click to select the Server of your choice.
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3 Click the Database drop-down arrow, click to select the Database of 
your choice, and then click the OK button.

The following diagram shows the IRSS Server and Database Selection dialog 
box.

To close the current database
• On the File menu, click Close Database.

To print T-Card labels
• On the IRSS task bar, click the Print T-Card Labels icon.

The following diagram shows the location of the Print T-Card Labels icon.

To print a Checkout Form
1 On the IRSS task bar, click the Print Checkout Form icon.

The following diagram shows the location of the Print Checkout Form icon.

Working with Index Lists and table views
The Tools menu allows you to modify Index Lists and customize the layout of 
your IRSS windows and screens.

Modifying Index lists can negatively impact other I-Suite programs and 
adversely affect your reports. Change an index list only after you have 
followed appropriate agency channels and have obtained proper approval.
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To add a new code to an Index List
1 On the Tools menu, click Index Lists.

2 On the Index Lists dialog box under Select Index List, click to select the 
Index List of your choice.

3 Scroll to the bottom of the table, and then click in the first available blank 
row, in the cell to the right of the .

4 Type the new data as appropriate for that Index List.

5 To save your entries, press TAB to advance the cursor to the next available 
blank row.

You must advance the cursor to the next available blank row or your entry 
will not be saved!

6 When finished, click the Close button.

The following diagram shows the Index Lists dialog box. In this example, the 
Index List for agency is selected 
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The following diagram shows the Index List for Status. The arrow points to 
the first available blank row.

Working with the Options dialog box
The Options dialog box lists five tabs that allow you to set parameters and 
define what is available to you in many IRSS screens. These tabs include:

• General. Change Other Column Titles, change the Table View to display 
only a certain set of records, add additional Kinds for QuickStats.

• Labels. Print barcode and T-card labe.s
• Active Fields. Display new field names on your screen.
• Field Sizes.Change the size of fields on your screen.
• Checkout Form. Customize the Checkout Form.

To change Other Column Titles

Changing Other Column Titles will reflect on the Add Resource/Edit Resource 
forms. Column titles in the table view, Report Design field names, and report 
titles are not affected and remain as “Other 1,” “Other 2,” and “Other 3.”

For more information about changing report titles, see “Working with Custom 
reports,” in the section, “Running and printing reports,” later in this IRSS 
User’s Guide.

1 On the Tools menu, click Options.

2 On the General tab under Other Column Titles, type to replace the 
existing text in the following boxes with the Titles of your choice

- Other 1
- Other 2
- Other 3.
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3 When finished, click the Apply button and then click the OK button.

The following diagram shows the General tab on the Options dialog box.

To change the Table View

Use caution when changing your default table view columns.

1 On the Tools menu, click Options.

2 On the General tab under Default Table View Columns, click to select 
the box of your choice, and then click the drop-down arrow to select the 
Title of your choice for the following boxes

- Column 1
- Column 2
- Column 3
- Column 4
- Column 5
- Column 6
- Column 7.

3 When finished, click the Apply button and then click the OK button.
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The following diagram shows the General tab on the Options dialog box. The 
arrow points to the Default Table View Columns.

To add additional Kinds for Quick Stats
1 On the Tools menu, click Options.

2 On the General tab under Additional Kinds used for QuickStats, click 
to select the first box, and then click the drop-down arrow to select the 
Kind of your choice.

3 Add additional Kinds as appropriate.

4 When finished, click the Apply button and then click the OK button.

The following diagram shows the General tab on the Options dialog box. The 
arrow points to the Additional Kinds used for QuickStats columns.
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To change field sizes
1 On the Tools menu, click Options.

2 On the Options dialog box, click the Field Sizes tab.

3 On the Field Sizes tab under Field Sizes to be used for Custom Reports 
click the Field Size box for the corresponding Field Name that you want 
to change, and then type to replace the existing Field Size with the new 
Field Size number.

4 Change additional Field Sizes as appropriate.

5 When finished, click the Apply button and then click the OK button.

The following diagram shows the Field Sizes tab on the Options dialog box.

To display a new field name
1 On the Tools menu, click Options.

2 On the Options dialog box, click the Active Fields tab.

3 For each Field and for each resource type (A, C, E, O), click to select or 
click to clear the appropriate check boxes of your choice.

4 When finished, click the Apply button, and then click the OK button.
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The following diagram shows the Active Fields tab on the Options dialog box.

To customize a Checkout Form
1 On the Tools menu, click Options.

2 On the Options dialog box, click the Checkout Form tab, and then click 
the Customize Checkout Form button.

3 On the Checkout Form dialog box under Logistics Section, click to 
select one or more of the check boxes of your choice

- Supply Unit
- Communications Unit
- Facilities Unit
- Ground Support Unit.

4 Under Planning Section, click to select the Documentation Unit check 
box, as appropriate.

5 Under Finance Section, click to select the Time Unit check box, as 
appropriate.

6 Under Other Section, click to select the Security Unit check box, as 
appropriate, and then complete the following fields as appropriate

- To add an additional unit in the Other Section, click to select the 
check box, and then type the unit name of your choice in the text 
box.

- Complete the second check box and unit name as appropriate.
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7 When finished, click the OK button on the Checkout Form dialog box, 
click the Apply button and then click OK on the Options dialog box.

The following diagram shows the Checkout Form tab on the Options dialog 
box.

The following diagram shows the Checkout Form dialog box.
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Running and printing reports
The Reports menu allows you to run and print standard reports and to create 
custom reports. Topics in this section include:

• Understanding queries, wildcards, and date ranges
• Working with standard reports
• Working with custom reports.

Understanding queries, wildcards, and date ranges
This section briefly introduces how to efficiently create queries, use 
wildcards, and specifying a range of dates when running standard and custom 
reports. Remember these key points:

• When developing an SQL query and where clauses, type the statements 
into a word processor such as Notepad or MS Word, and then copy and 
paste it into the dialog box.

• Type your keywords in uppercase.
• Separate each condition of the where clause with a new line to give visual 

structure to the SQL statement.
• A wildcard allows you to retrieve records that include the string of 

characters you specify. In IRSS, this wildcard is the “%” (percent sign).

Working with standard reports
This section explains how to select and sort available fields to produce 
standard reports, and how to create a custom “where” clause in SQL.

To run and print a standard report
1 On the Reports menu, click Run Reports, or click the Run Reports 

icon.

2 On the Run Reports dialog box under Incident Reports, click to select 
one of the following

- Aircraft Report
- Crew Report
- Equipment Report
- Overhead Report
- 209 Resource List
- Checkout Form
- Daily Cost Estimate
- Demob Planning Report
- R&R Report
- Qualifications Report
- Section Report
- Unfilled Orders Report.
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3 For the Incident Report you selected in step 2, complete the Report 
Parameters as appropriate.

4 To preview the report, click the Preview button, and then click the Print 
Report button.

5 To print the report without previewing, click the Print button, and then 
click OK on the Print dialog box.

The following diagram shows the location of the Run Reports icon.

The following diagram shows the Run Reports dialog box.

To display all overhead resources not demobed from Nevada - an 
example
1 Click the Overhead button.

2 Under Demobs, click to select Exclude.

3 On the filter bar, click in the HomeUnitCode box, type NV%, and then 
click the Filter button.
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The following diagram shows the table view of overhead resources. The 
arrow points to the Exclude option.

The following diagram shows the resulting filtered record.

To print a filtered record

You can copy and paste the filtered record into most any word processing or 
graphics software.

1 Obtain the filtered record of your choice.

2 On your keyboard, press ALT + PRINT SCREEN.
September 9, 2004 37



Incident Resource Status System User’s Guide
3 Open the word processing or graphics software package of your choice, 
and then create a new document.

4 Press CTRL +V.

5 On the File menu, click Print.

To design, save, and print a report
1 On the Reports menu, click Design Reports.

2 On the Design Reports dialog box on the Design Regular tab, type the 
name of the report in the Title box.

3 Under Fields, click to select the following Fields of your choice, in order 
in which you want to sort.

4 If appropriate, type a valid SELECT....WHERE statement in the Select 
box.

5 Under Line Spacing, click to select on of the following

- Single
- 1.5
- Double.

6 To preview the report, click the Preview button, and then click the Print 
Report icon.

7 To save your report, click the Save button.

The following diagram show the Design Reports dialog box.
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To design a regular report using a where clause - an example
1 On the Reports menu, click Design Reports.

2 On the Design Reports dialog box on the Design Regular tab, type the 
name of the report in the Title box.

3 Under Fields, click to select the following Fields, in the following order

- RequestNumber
- Name
- KindDesc
- HomeUnitCode.

4 In the Select box, type the following WHERE clause

status <> ‘0’
and homeunitcode like ‘NV%’
and reqcat = ‘0’

5 To preview the report, click the Preview button.

6 To save the report, click the Save button.

The following diagram shows the resulting Design Regular tab on the Design 
Reports dialog box.
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Working with custom reports
This section explains how to select, sort, group, and order fields using SQL 
statements to create custom reports. Remember these key points when 
working with custom reports:

• Queries. Also known as data retrievals, search the database and fetch 
information you requested in the most efficient way possible.

• SELECT. Identifies the data.
• FROM. Identifies the table.
• WHERE. Limits the data that the Select statement returns.
• BETWEEN. Spans two specific fields, such as between two dates.
• GROUP BY. Organizes data into sets.
• COUNT(*). Gives a summary value per set.

The Design Reports Help File is a valuable resource for understanding and 
creating correct SQL syntax. 

 To access the Help file for creating SQL statements
1 On the Design Reports dialog box, click the Help button.

2 When finished reviewing the information, click the Close button.

The following diagram shows the Design Report Help window.
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To create a custom where clause and between clause for an SQL 
query - an example
1 On the Reports menu, click Design Reports.

2 On the Design Reports dialog box, click the Design Advanced tab.

3 In the Title box, type the name of the report.

4 In the Select box, type the following

SELECT requestnumber, name, kinddesc
homeunitcode
FROM q_basic_rpts
WHERE status <> ‘D’
and Checkindate between ‘07/01/2004’ and ‘07/14/2004’
and homeunitcode like ‘NV%’
and reqcat = ‘0’

5 To preview the report, click the Preview button.

6 To save the report, click the Save button.

The following diagram shows the resulting Design Advanced tab on the 
Design Reports dialog box.
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To change report titles using an SQL “AS” statement - an example
1 On the Reports menu, click Design Reports.

2 On the Design Reports dialog box, click the Design Advanced tab.

3 In the Title box, type the name of the report.

4 In the Enter a complete sql statement box, type the following

SELECT 
Other1 AS ‘Spike Camp’,
Other2 AS ‘Crew Reps’ 
from Resources

The following diagram shows the resulting Design Advanced tab on the 
Design Reports dialog box.
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